Jammassinia

Issue with RSA - not being recognised by my wallet when unlocked

7 posts in this topic

Hi all,

 

Haven't been able to stake for a few months now, partially because I stopped trying too during January when my main cruncher went out of action for a while and there seemed little point, and also because of the issue I have been having which I'll put forth now.

 

I have tried various different config file settings, rebuilding the blockchain, reinstalling the client, regularly updating the client etc without success, so I'm really now stuck and in need of real help with this one.

 

Previously, when the wallet was staking regularly, the DPOR Weight on my wallet was quite high, and would decrease each time I staked by an arbitrary amount (presumably the amount needed to stake at that difficulty?)

I have always presumed this number was made up of two parts - my coin balance and RSA balance, since the lowest point has always matched my coin balance at the time, and the number always increased when I wasn't staking, just as RSA should. Please correct me if any of this isn't accurate, but I'm sure I can't be too far off?

 

Now, however, this number only ever holds 2 specific values. The lowest point as described above, which is equal to my integer coin balance of 3443 (decimal part seems to be ignored), and a value of 1403443, which is only present when I first open the wallet, and returns almost instantly to 3443 once the wallet is unlocked for staking.

Briefly, before the move to 3443, the wallet will produce a time estimate of 15 seconds for POR reward, and 1 hour for interest. This then changes to no readout for POR reward at all, and anything from 24 days to 41 days depending on network difficulty for interest.

 

As mentioned above, my main cruncher had blown up, and when replacing parts I have upgraded, so I'm now crunching almost 3x faster than my previous best. Still no RSA generation to move away from the 3443 figure and begin staking again after a month at this rate, and no sign of payment for any of the last 4 months. It's almost like my RSA is no longer going down on record.

This is particularly bizarre considering every project I have ever participated in is on the whitelist, so it's not like my projects are being removed from the list and therefore don't count..

 

Gridcoin-stats estimates my owed balance to stand at around 1800 GRC, and can clearly see my RAC, RSA etc for these estimates, which is suggesting over a 50% increase in my balance, so clearly I would love to get this sorted before the 6 month period comes about and I start losing my owed coins.

 

Note also I use the Gridcoin wallet on the same laptop I always have, so that the main desktop can maximise my Boinc output. However, I have moved house and wondered whether the IP address change has perhaps locked me out of staking somehow? I can't advertise a new beacon since I'm already in the network so this is something I haven't yet tried... but presumably as I'm still present in the network I wouldn't need too?

 

Anyway, I'll stop rambling and hand this over to the experts. Thanks for any help you can provide!

Share this post


Link to post
Share on other sites

Then you have "CPID INVALID" and this mean that you don´t have the keypairs to CPID in config. Check Wallet backup folder in user/appdata/Gridcoinresearch look in .conf file. New keys will be generated when you send new beacon, but the old need to expire or be deleted first.

 

This was added for 4-5 month, this was to protect users CPIDs. Read about beacon v2, more info here in supportforum about this.

Share this post


Link to post
Share on other sites

Then you have "CPID INVALID" and this mean that you don´t have the keypairs to CPID in config. Check Wallet backup folder in user/appdata/Gridcoinresearch look in .conf file. New keys will be generated when you send new beacon, but the old need to expire or be deleted first.

 

This was added for 4-5 month, this was to protect users CPIDs. Read about beacon v2, more info here in supportforum about this.

Not true.

The CPID Invalid message HAS been present in the PAST, but I solved that a couple of months ago when I thought along the same lines, by redoing the config file and new keys. I have both the keys for my CPID already in the config file, and I have a valid beacon, which is why I'm now at a complete loss as to what has gone wrong. I have also received a payment (my last one) under the updated system so I know that works (or was working).

Interestingly, I have just checked Gridcoin Stats again, and the balance they see for my account is lower than the balance on my wallet by roughly the same amount as that payment. Which I presume means I am on a fork? But then again, I have rebuilt the block chain countless times already, so that, too, seems unlikely.

Gonna try going to an earlier backup and re-downloading the blockchain again to see if I can get back into sync that way, but after that I need fresh ideas. This doesn't seem like a usual problem that can be solved with the normal steps...

Share this post


Link to post
Share on other sites

No change, so I presume Gridcoin Stats estimates are out by a hundred GRC or so.
Still no CPID Invalid message either. Any other ideas before I try and get my beacon deleted?

Share this post


Link to post
Share on other sites

Requested beacon to be deleted. In doing so I found the account my beacon/CPID was attached too in the "execute beaconreport" list wasn't even one attached to my wallet. It now is attached since it is now set as CPID_Address as per the deletion instructions.
I'm worried though, since this is getting stranger and stranger the more I dig into it, some serious corruption must have occurred in my wallet at some stage?

Share this post


Link to post
Share on other sites

Still waiting on RTMoney to get rid of my beacon. Around a week until it deletes itself and I start losing some of my potential earnings for good :/

Anyone able to ask him to check his messages on here / transactions so he knows I need it sorting?  :(

Share this post


Link to post
Share on other sites

SUCCESS!

Something in the new update must have fixed my wallet, just staked POR for the first time in 5 months. Still cautious as to whether it is working completely healthily, but it certainly takes some of the time pressures off now that I can afford to wait for the beacon to dissolve naturally. In theory I've just been paid for the oldest credit and now have time to create a new one  before I lose anything. :D 
However, wallet has since gone out of sync again, so won't be marking as solved until it's all confirmed...  :blink:

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.