Jump to content

NEWS
  • WELCOME TO CRYPTOCURRENCYTALK!
  • We've upgraded the website with a lot of new features!
  • 3 NEW THEMES! Click on the + Themes button above!
  • Notice about SOCIAL LINKS: UPDATE YOUR SOCIAL LINKS
  • New video section, add your videos: VIDEO SECTION
  • Advertising will be available shortly, hold tight.
  • If you have any issues with the new site, please submit a support ticket: SUPPORT
Ken Foster

[ANN] (ADC) AudioCoin - A Digital Currency For The Music Industry

Recommended Posts

Ken and Jonny -

 

I tested the Mac Wallet and it crashed for me as well when opening.

 

I have a version of the OS X wallet that I built for Mavericks and Yosemite with MacPorts and a user-compiled version of the boost libraries.  If you would like to test this while the other wallet is having issue, let me know and I can send it to you.

Share this post


Link to post
Share on other sites

Ken and Jonny -

 

I tested the Mac Wallet and it crashed for me as well when opening.

 

I have a version of the OS X wallet that I built for Mavericks and Yosemite with MacPorts and a user-compiled version of the boost libraries.  If you would like to test this while the other wallet is having issue, let me know and I can send it to you.

 

Sure, i could test on Yosemite. Please send through and thanks.

Share this post


Link to post
Share on other sites

big dump just knocked coin price down 300% : :(

 

big dump just knocked coin price down 300% :

 

Probably day traders or one of the big miners. A little bit short sighted as the price should be going up approaching our press and industry launch at MIDEM next week. Good buy though. I will pick some up myself at that price.

Share this post


Link to post
Share on other sites

Ken and Jonny -

 

I tested the Mac Wallet and it crashed for me as well when opening.

 

I have a version of the OS X wallet that I built for Mavericks and Yosemite with MacPorts and a user-compiled version of the boost libraries.  If you would like to test this while the other wallet is having issue, let me know and I can send it to you.

 

It's not the boost libraries causing the problem, it's the Berkeley DB that is.  When you built with macports, did you use qt4?  There's a pretty significant issue with the qt5 port.  Also, with macports there's an issue with the included boost when you update to the latest.  You've solved that one by just compiling your own from source there :)

Share this post


Link to post
Share on other sites

It's not the boost libraries causing the problem, it's the Berkeley DB that is.  When you built with macports, did you use qt4?  There's a pretty significant issue with the qt5 port.  Also, with macports there's an issue with the included boost when you update to the latest.  You've solved that one by just compiling your own from source there :)

I saw in the report that it had to do with the Berkeley DB.  I know it wasn't the boost issue.  I was just replying with my setup for how I built the wallet. And yes, I am using qt4.  I had some issues with certain wallets using homebrew, so I switched back to macports and have gotten all the wallets that I have tried to compile to run correctly after that.  

 

I wonder why BDB is throwing errors since it is contained within the package.  It is a curious issue that is occurring.

Edited by ctgiant

Share this post


Link to post
Share on other sites

I saw in the report that it had to do with the Berkeley DB.  I know it wasn't the boost issue.  I was just replying with my setup for how I built the wallet. And yes, I am using qt4.  I had some issues with certain wallets using homebrew, so I switched back to macports and have gotten all the wallets that I have tried to compile to run correctly after that.  

 

I wonder why BDB is throwing errors since it is contained within the package.  It is a curious issue that is occurring.

It is indeed.  I'm not sure why it's happening at all since the libraries are linked into the app itself on the build.  I've seen a few other wallets with the same issue and some people forcibly statically linked in the libraries... while a solution, it's not the cleanest approach.

 

Edit:

 

I've rebuilt the wallet, and the output from otool still shows exactly what I was expecting:

otool -L Audiocoin-Qt.app/Contents/MacOS/Audiocoin-Qt
Audiocoin-Qt.app/Contents/MacOS/Audiocoin-Qt:
	@executable_path/../Frameworks/libqrencode.3.dylib (compatibility version 8.0.0, current version 8.4.0)
	@executable_path/../Frameworks/libminiupnpc.10.dylib (compatibility version 0.0.0, current version 0.0.0)
	/System/Library/Frameworks/Foundation.framework/Versions/C/Foundation (compatibility version 300.0.0, current version 1151.16.0)
	/System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices (compatibility version 1.0.0, current version 48.0.0)
	/System/Library/Frameworks/AppKit.framework/Versions/C/AppKit (compatibility version 45.0.0, current version 1343.14.0)
	@executable_path/../Frameworks/libssl.1.0.0.dylib (compatibility version 1.0.0, current version 1.0.0)
	@executable_path/../Frameworks/libcrypto.1.0.0.dylib (compatibility version 1.0.0, current version 1.0.0)
	@executable_path/../Frameworks/libdb_cxx-4.8.dylib (compatibility version 0.0.0, current version 0.0.0)
	@executable_path/../Frameworks/libboost_system-mt.dylib (compatibility version 0.0.0, current version 0.0.0)
	@executable_path/../Frameworks/libboost_filesystem-mt.dylib (compatibility version 0.0.0, current version 0.0.0)
	@executable_path/../Frameworks/libboost_program_options-mt.dylib (compatibility version 0.0.0, current version 0.0.0)
	@executable_path/../Frameworks/libboost_thread-mt.dylib (compatibility version 0.0.0, current version 0.0.0)
	@executable_path/../Frameworks/QtWidgets.framework/Versions/5/QtWidgets (compatibility version 5.4.0, current version 5.4.1)
	@executable_path/../Frameworks/QtGui.framework/Versions/5/QtGui (compatibility version 5.4.0, current version 5.4.1)
	@executable_path/../Frameworks/QtCore.framework/Versions/5/QtCore (compatibility version 5.4.0, current version 5.4.1)
	/System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration (compatibility version 1.0.0, current version 1.0.0)
	/System/Library/Frameworks/IOKit.framework/Versions/A/IOKit (compatibility version 1.0.0, current version 275.0.0)
	/System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL (compatibility version 1.0.0, current version 1.0.0)
	/System/Library/Frameworks/AGL.framework/Versions/A/AGL (compatibility version 1.0.0, current version 1.0.0)
	/usr/lib/libc++.1.dylib (compatibility version 1.0.0, current version 120.0.0)
	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1213.0.0)
	/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 1151.16.0)
	/System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices (compatibility version 1.0.0, current version 62.0.0)
	/usr/lib/libobjc.A.dylib (compatibility version 1.0.0, current version 228.0.0)

As you can see, the references to boost and Berkeley DB are properly within the application itself.

Edited by jonnybravo0311

Share this post


Link to post
Share on other sites

Probably day traders or one of the big miners. A little bit short sighted as the price should be going up approaching our press and industry launch at MIDEM next week. Good buy though. I will pick some up myself at that price.

yes, very short sighted but unfortunately there's always going to be the dumpers... as I said before I plan to hold my 10,000,000 for a quite a while ;-)

Share this post


Link to post
Share on other sites

Tomorrow 29th and Sat 30th May we'll be at the IndieWeek Europe Music Festival in Manchester, UK.
We'll be explaining AudioCoin and talking to potential partners.

 

Thanks to Jonny Bravo and ctgiant for help with the wallets. The new OSX wallet is now on our Github.

Share this post


Link to post
Share on other sites

Tomorrow 29th and Sat 30th May we'll be at the IndieWeek Europe Music Festival in Manchester, UK.

We'll be explaining AudioCoin and talking to potential partners.

 

Thanks to Jonny Bravo and ctgiant for help with the wallets. The new OSX wallet is now on our Github.

Glad to help out.  Sorry to everyone who tried the initial wallet I built.  Thankfully I was able to get around the issue and provide a wallet that is working on all Macs (OS X Mavericks or higher have been tested - I'd be interested to see if anyone has a Mac with 10.7 or 10.8 if this wallet works with it).

 

Have fun at the festival, Ken!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using CRYPTOCURRENCYTALK.COM, you agree to our Terms of Use.